Yossi Dahan [BizTalk]

Google
 

Thursday, February 08, 2007

"The send port configuration corresponding to the message was not found"

Today our operations team spotted the following error in the event log of one of our servers:

A message going to a one-way send port is being suspended. Reason:The send port
configuration corresponding to the message was not found.
This usually
happens when a send port was deleted while it still had some active messages.



This has sent us chasing in the wrong direction for a short while trying to think who has deleted what on the server.
Shortly after the real cause of this issue became clear through another event in the event log which noted that access to the SSO database was denied.
Of course, as the port configuration is stored in the SSODB, if access to this databsae is restricted port configuration cannot be accessed and so the message could not be delivered

Labels:

6 Comments:

  • Thanks Yossi,
    This was very helpful.

    I added the user (Logon) that the Host Instance runs under (i.e. this host instance is also the send handler for my Send Port) to the "SSO Administrators" group and the problem was gone.

    By Anonymous Anonymous, at 24/04/2007, 03:09  

  • Whilst adding the host user to the SSO Administrators group will definitely work, I don't think Microsoft will reccomend that. Granting access to that group means the host user has a far greater level of privledge than needed.

    The correct group would be the Biztalk Application Users group (or your equivalent).

    This will allow the host instance access to the right parts of the right databases. The error message can sometimes be quite decieving!

    By Blogger Ben Szymkow, at 06/06/2007, 08:48  

  • thanks for making this very important point, of course you are absolutely right!

    By Blogger Yossi Dahan, at 06/06/2007, 09:35  

  • Hi ,

    I added the Group users yo SSO Admin but still its throwing the same error.

    A message going to a one-way send port is being suspended. Reason:The send port configuration corresponding to the message was not found.
    This usually happens when a send port was deleted while it still had some active messages.

    MessageId: {4FBD0B0C-F5AC-41E1-8F5E-78ACC300E47F}
    InstanceID: {FCA1B7BB-21C8-4B22-928E-14652E08A4E0}

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp."

    As soon as I put the file in receive location this error gets generated.Is there any other solution to this problem.
    "

    By Blogger S kansay, at 27/03/2008, 04:38  

  • In my case it was definitely access restrictions on the database.

    I'm sorry - I don't know of any other causes.

    You could try to use the SQL Profiler or similar tools to try and figure out what's failing.

    By Blogger Yossi Dahan, at 31/03/2008, 21:46  

  • Oh Thank you Yossi!!! I am receiving this error permanentaly but its not affecting me anywhere...Application is running smooth without any problem!!!!

    By Blogger BizTalk2006, at 01/04/2008, 13:47  

Post a Comment

<< Home